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A Bluetooth ESP32 TFT + Touch Macro Keypad)

by DustinWatts

Controlling your computer by using hotkeys and macros is a great way of speeding up your work�ow. Unfortunately a
device dedicated to doing that (for example Elgato's Stream Deck) will cost you about $120.

That is why I designed FreeTouchDeck. FreeTouchDeck will cost you about $20 (including shipping!) to make. It uses an
ESP32 and a 3.5" touch screen. Keystrokes and macros are send via Bluetooth to your Windows, MacOS, or Linux
computer.

You can customize your FreeTouchDeck by using the con8gurator. The con8gurator is a webpage that is hosted on the
ESP32 itself. You can customize menus, buttons, logos and colours. You can also create your own button logos and
upload them.

This is a really simple build and will take up less then an hour of your time + a few cups of co:ee. I designed it so it can be
build using parts that can be easily found on AliExpress and Banggood but can also be found locally if you do not want
to wait a while before the postman comes.
Supplies:

A 38-pin ESP32-WROOM-32 Development Board AliExpress / Amazon
An ILI9488 TFT screen with XPT2046 touch controller AliExpress / Amazon
An optional ESP32 + TFT Combiner PCB

Tools:

A soldering iron and solder.
Wire strippers (if you are not using the PCB).
Flush cutter.

Even better than buying the loose parts and have to build it, is using the ESP32 TouchDown. Which I designed and sell. It
is an ESP32 with an capacitive touch screen. It has USB-C and battery management for fully wireless operation. It comes
with an SD Card slot and a passive buzzer. You can buy it here.
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Step 1: Learn More About FreeTouchDeck

Step 2: Get the Parts You'll Need

Before you start this project it might be a good idea to watch the video I made. The video in itself isn't a how-to, but more
of an introduction to what FreeTouchDeck is and what it can do for you!

Watched the video? Let's get the parts you'll need!

https://www.youtube.com/watch?v=soIGV6BszcM

If you do not already have an ESP32 and an ILI9488 TFT + Touchscreen lying around. You can 8nd them pretty cheap on
AliExpress. I used these parts:

- A 38-pin ESP32-WROOM-32D Development Board from AliExpress or Amazon*

- An ILI9488 TFT screen with XPT2046 touch controller from AliExpress or Amazon*

- An optional ESP32 + TFT Combiner PCB ( Gerber 8le)

Not all ILI9488 TFT screens are created equally. It is important to make sure you have selected  a screen with touch!
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*Full disclosure: these are a�liate links
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Step 3: Hardware: Connect the TFT Screen to the ESP32

The wiring may seem a bit daunting at 8rst. But don't let all the wires scare you. It is pretty straight forward. The images
above will help you when you wire your TFT + Touchscreen to your ESP32. This is also decision making time. There are few
options when it comes to connecting the two together. You can use a breadboard, you can use prototyping board or you
can order a PCB speci8cally to connect the ILI9488 + touch to the 38-pin ESP32 DevKitC. I'd like to point out that the
breadboard option is only an option for testing your connections and screen. It is not very practical to have on your desk
and loose connections can cause problems.

It is important to know that these screens run at 3.3V. Connecting them to 5V can cause damage!

These are the connections you need to make from the ESP32 -> ILI9488:

3.3V -> VCC

GND -> GND

GPIO15 -> CS

GPIO4 -> RESET

GPIO2 - > DC/RS

GPIO23 -> SDI(MOSI) and T_DIN

GPIO18 -> SCK and T_CLK

GPIO32 -> LED

GPIO21 -> T_CS

GPIO19 -> T_DO

GPIO27 -> T_IRQ

SDO(MISO) is not used for the TFT screen, so you are left with one unconnected pin on the TFT module. That's ok!

If you like to order a PCB designed to make it easy to connect the ESP32 to the TFT screen, you can download the gerber
8les here: https://github.com/DustinWatts/ESP32_TFT_Combiner

You can also order them directly from PCBWay where I had mine made:

https://www.pcbway.com/project/shareproject/ESP32_TFT_Combiner_V1.html
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Step 4: Using the Web Installer to Install the Firmware. (Recommended)

Next there are two options. You can install all the software manually (Step 5 through 8). Or use the new (as per April the
18th 2022) FreeTouchDeck Web Installer. I recommend the Web Installer as it will save you time and there a less
chances you will make a mistake.

For the Web Installer to work, you will need to use Chrome, Opera or Edge as your browser!

Go to https://install.freetouchdeck.com

Select the "ESP32 DevKitC" option

Click “Connect”

A pop-up window telling you that install.freetouchdeck.com wants to connect to a serial port pops up. Plug in your newly
made FreetouchDeck. A new port now shows up in the list.

Select this port and click “Connect”

After it connects, click “Install FreeTouchDeck”.

A message prompts you with the version that is about to be installed and that all data will be erased before the new
installation begins. This is 8ne, there is nothing important on our device anyway.

Click “Install”.

Note that at some point the installation might seem to “hang”. It I actually not, the percentage will not update, but the device is
really being programmed. So nothing to worry about!

After some time the installation will be done. And on your FreeTouchDeck you are greeted with a calibration screen. This
is the time to skip to Step 8! (Step 9 if you wish to print a case later)
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Step 5: Software: Installing Arduino IDE Libraries
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Installing the Arduino IDE ESP32 core.

Go to Arduino -> Preferences and click on the icon behind the input 8eld for Additional Board Managers URLs.

Next, copy and paste the following link (without quotes) in the popup box:

"https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json"

Click OK and OK.

Next, go to Tools -> Board: -> Board Manager and search for "ESP32". Install the latest version and click "Close".

Installing the necessary libraries.

FreeTouchDeckuses a few (some might call 6 more than a few) libraries. Three of these libraries can be installed though
the the Library Manager. Go to Sketch -> Include Library -> Manage Libraries and search for, and install the following
libraries:

Adafruit-GFX-Library
TFT_eSPI
ArduinoJson

The other three libraries need to be downloaded manually. For each of them the process is the same so I'll describe just
one of them.

Go to "https://github.com/T-vK/ESP32-BLE-Keyboard", click on "Releases" and under the latest release, click on "Assests"
and "Download _libraryname_.ZIP". In the Arduino IDE, go to Sketch -> Include Library -> Add .ZIP library. You can
also directly unpack the folder in the .zip in to your libraries folder (usually "Documents/Arduino/libraries."

Repeat for the following libraries:

"https://github.com/me-no-dev/ESPAsyncWebServer"
"https://github.com/me-no-dev/AsyncTCP"

If there is no release, then on the main page click "Code", and then "Download ZIP"
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Step 6: TFT Screen Configuration

Before compiling and uploading the FreeTouchDeck.ino sketch, you will have to edit the user_setup.h 8le included with
the TFT_eSPI library. This can be found in your Arduino sketchbook folder under "libraries". If you have not renamed the
TFT_eSPI library folder, the 8le user_setup.h can be found in TFT_eSPI-master. Here you will have to uncomment the lines
that apply to your hardware con8guration.

To make things easier, you can 8nd the user_setup.h 8le you will need for this project in the downloaded repository in
the "user_setup.h Examples" folder. Copy the 8le " ESP32_Dev_Kit_V1_ILI9488_Resistive.h" to "/TFT_eSPI-master/".
Rename the "User_Setup.h" that is already there to "User_Setup.old" (this way you keep the original in case something
goes wrong). Now rename "ESP32_Dev_Kit_V1_ILI9488_Resistive.h" to "User_Setup.h". (<- CASE sensitive!) Save and
close the 8le.
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Step 7: Download FreeTouchDeck.ino and Upload to the ESP32

ESP Sketch Data Upload Tool

FreeTouchDeck uses the SPIFFS (ESP32 �ash memory) to store con8guration and images that are used. You'll need to
upload these to the ESP32 before you upload the sketch to the ESP32. For this you'll need the ESP32 Sketch Data Upload
tool. You can download this from Github: "https://github.com/me-no-dev/arduino-esp32fs-plugin". Follow the
instructions on the Github to install the tool:

Download the tool archive from releases page.
In your Arduino sketchbook directory, create tools directory if it doesn't exist yet.
Unpack the tool into tools directory (the path will look like /Arduino/tools/ESP32FS/tool/esp32fs.jar).
Restart Arduino IDE.

(On MacOS create the tools directory in ~/Documents/Arduino/ and unpack the 7les there).

FreeTouchDeck.ino

On Github you can 8nd the full source code for FreeTouchDeck. Go to the FreeTouchDeck Github repository and click
"Code" and "Download .ZIP": https://github.com/DustinWatts/FreeTouchDeck
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Extract and rename the extracted folder to "FreeTouchDeck". Open the FreeTouchDeck.ino sketch in the Arduino IDE. This
will also open a few other header (.h) 8les. You do not need to touch (pun intended) these.

**Since version 0.9.11 the next step is no longer necessary! You can still edit this if you want but if you do not
edit the con<g before uploading, if you start the con<gurator and it can't connect to an Access Point it will start
one. You can then enter the con<gurator and edit you wi< settings in there.**

Set your WiFi Settings

Once you have the FreeTouchDeck.ino sketch open go to the folder you have the FreeTouchDeck.ino sketch in, open
"/data/con7g/wi7con7g.json". This is where you can enter you're WiFi SSID and Password so you can connect to your
FreeTouchDeck to con8gure it

change "YOUR_WIFI_SSID" to the WiFi SSID you want FreeTouchDeck to connect to.
change "YOUR_WIFI_PASSWORD" to the Password that WiFi network uses.

Upload the data folder

Before you upload the data folder to the ESP32, you'll 8rst have to select the right partitioning scheme.

Go to Tools -> Board and select ESP32 Dev Module.
Still under Tools, select Partition Scheme. -> "No OTA (2MB APP/ 2MB SPIFFS)".
Plug in the ESP32.
Click on Tools and select "ESP Sketch Data Upload".

Tip!: If the data upload fails, chances are you have the serial monitor open. If this happens, close the serial monitor and try
again.

Upload the sketch to the ESP32

After the data folder is successfully uploaded, you can go ahead and upload the FreeTouchDeck.ino sketch to the ESP32.
The settings under tools besides the Partition Scheme can be left to the default.

Go to "Sketch" and select "Upload". This may take a while because it is a large sketch.
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Step 8: Printing a Case (optional)

O: course not necessary, but when you have built your FreeTouchDeck you can print a case for your FreeTouchDeck. This
design will 8t the screen and ESP32 with or without the combiner PCB.

The case is designed to be a press-8t. You could however add a touch of CA glue (crazy glue) to keep the top 8rmly
attached to the bottom.

You can 8nd the case on Thingiverse: https://www.thingiverse.com/thing:4661069

I printed it in PLA with a 0.2 mm layer height. The top doesn't need support if you print it face down. The bottom needs
some minimal support if you print it with the opening down.

If you like to modify the case to your liking, you can 8nd the Fusion 360 8les on Github:
https://github.com/DustinWatts/FreeTouchDeck/tree/master/case/ESP32_TFT_Combiner_Case

I've included some images of my slicer.

A Bluetooth ESP32 TFT + Touch Macro Keypad): Page 14

https://www.thingiverse.com/thing:4661069
https://github.com/DustinWatts/FreeTouchDeck/tree/master/case/ESP32_TFT_Combiner_Case


A Bluetooth ESP32 TFT + Touch Macro Keypad): Page 15



A Bluetooth ESP32 TFT + Touch Macro Keypad): Page 16



Step 9: First Boot

After uploading the sketch and all the 8les to the ESP, at 8rst boot a touch calibration screen is displayed. This is so that
FreeTouchDeck knows where all the corners are and can determine if a touch falls within the boundaries of a button.

A calibration 8le is saved on the ESP 8lesystem. So, if you re-upload 8les to the ESP using "ESP32 Sketch Data Upload", the
calibration 8le is deleted and you will be presented with the calibration screen again.

The home screen has 6 buttons. These are all "menu buttons" in that they take you to an underlying menu. These buttons
have a di:erent colour as the function buttons in the menu's. On the home screen you will also 8nd a "settings" menu.
This will take you to a menu were you can enter the con8gurator.

Once the home screen is loaded, BLE is also started. You can now connect with your computer to the FreeTouchDeck. You
might have to refresh your Bluetooth device list on your computer. After you see "FreeTouchDeck", you can connect to it.
To test if Bluetooth works properly you can go in to the "Music" menu. And press "Mute" to see if a BLE connection is
established.
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Step 10: Configure Your FreeTouchDeck

You can now customize your FreeTouchDeck. FreeTouchDeck hosts a website on the ESP32 itself where you can
con8gure the menu's and the button's each menu has. You can also customize the colors and upload your own logo's.

To start the con8gurator. Touch the bottom right button so go to the " Settings" page and then touch the "WiFi" button
on the top left. Once the con8gurator has started you can open a web browser and go to freetouchdeck.local.

To learn more about how to use the con8gurator check out the Wiki on Github.
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Step 11: Final Note and Troubleshooting

Troubleshooting

Not using the combiner PCB but using a breadboard can make for bad connections and a screen that doesn't seem to
work. So if you seem to have a screen that is not working, double and triple check your connections!

Also if newer versions of the ESP32 core of TFT_eSPI (or any library for that matter) contain changes that need a code
change, things might not work. I try to catch these changes and update the code accordingly, but it may not always
happen straight away.

If you comment with any complications, please include the following information:

Are you using the combiner PCB?
Are you using a breadboard?
Did you solder the connections using a protoboard or point to point?
What version of the ESP32 core are you using?
What version of the TFT_eSPI library are you using?
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Awesome and very useful project, big thanks for the great instructions!

love the anime pcb there

Hi Dustin, 
I've made this one with a 2.8" TFT touch screen (ILI9341). 
Had to make the following modifications to your code to make it work:
- Change the resolution and the touch-rotation statements in the INO file to match the resolution
(320x240)
- Fix a compilation error in Action.h (bleKeyboard.write(KEY_NUM_ASTERIX) instead of
bleKeyboard.write(KEY_NUM_ASTERISK))
- Change the TFT-driver to ILI9341_DRIVER in /TFT_eSPI/User_Setup.h
Works like a charm! I mainly use it with some custom logo's to operate MS Teams conference
keys (mute mic, mute video, raise hand, etc etc).
Thanks for this project!
Michael

LOVE this project! Got it all up and running with a few bumps here and there, but was a great
learning experience! Is there a way to remove the white border from the buttons? 

Hi Dustin.When upload. There is error message 'NUM_0' was not declared in this scope. How to
add in?

Gracias por compartir este proyecto.
Aunque me dio problemas la primera TFT, con la segunda ha salido funcionando a la primera.
A falta de la caja, aqui está totalmente personalizado.
Saludos

This makes troubleshooting for me much easier, as otherwise I have to ask it 8rst before I can help you :)

Final Note

Thank you for taking the time to read this Instructable! I hope this is useful to you and you've had fun building your
FreeTouchDeck

If you have any questions or are stuck somehow, do not hesitate to leave a comment, or join me on one of my social
channels.

YouTube: https://www.youtube.com/dustinwatts

Twitter: https://twitter.com/DustinWattsNL

Discord: https://discord.gg/RE3XevS
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Project very well done and easy to do, well explained even confusing me at times it was easy to
find an answer to the existing questions.

Hi Dustin, thanks for sharing this great project.
I have followed all the indications, reviewed connections, verified file path as well as the
User_Setup.h modification.
The loading of the sketch apparently correct, it does not throw any error, the Arduino IDE, once
the loading is finished, I reboot ESP32 and the TFT screen remains blank (white).
When I open the serial port and do a reset it indicates error in the SPIFFS according to attached
image.
Can you help me please?
Thank you.
Best regards.
Luis

Hi Rapidbit, Did you do the Sketch Data Upload step? Selecting 2MB APP/2MB SPIFFS is also
important when uploading the sketch....

Hi Dustin, thanks for your quick response.
Now I have the same problem as "erwinsanders ".
I have managed to upload the sketch and the "data" folder without errors.
From the mobile I see by BLE the device and I can connect, but I see nothing on the screen, I
have checked several times the wiring and the path to the User_Setup.h file, I use the one from
the repository.
Thanks

Solved:

Hi, one more question about touch... I have ordered exact the linked display from aliexpress. I can
clearly see the ~4 wires in the flat-cable from the touchscreen layer and the XPT2046 on
backside of the pcb. The display is mounted on your PCB and i used as an template
:ESP32_Dev_Kit_V1_ILI9488_Resistive.h 
(WIFI is not configured and connected)

Is there an video with the touch calibration ? (i see two times a symbol. I think it wants to tell me:
"touch me in in the middle of the circle to start calibration) But i dosnt matter if i touch the display
or not, it will go on after ~2 seconds and i see the 6 symbols...)

PS: I have two of this ESP32 Modules and two displays with the same behavior... So i should be
an configuration problem on my side (?)

Solved:

Hi, the problem is lost while im searching it...
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A) i had 2,5MOhm / 6MOhm between the Pin numbered with 21 at the ESP32 Module and
between GND and 3V3, That looks good for me...
B) i resoldered all Pins with Flux 
C) i used another Power Supply
=> I saw no change
D) auf setting #define REPEAT_CAL to true the calibration can be don and the device works...
I finally can't reproduce the reason. For example i tested calibration with the protection film on the
display that i had at the beginng an it works also...
Thank you very much for your support and the great project !

I have the same problem but I cannot solve it by performing the procedures you mention.

EDIT: My solution comment this line in the sketch: //#define USECAPTOUCH

A azum little project had alot of fun doing it and learnd some new great stuff!

Incredible prject. Thanks for creating and sharing it Dustin.
I started to buil the same day I saw the project! Luckily I had already an ESP (VROOM-32) and a
display (2.8 inch ILI9341) from other projects. I was a bit sceptical initially because both were
different from what is in the project. But it all worked in the end! I packed everything into a box
and added a LiPo + wireless charger. Obviously as I had no connector board, so there is
'kabelsalat' inside :)
I can see now how a capacitive (and a larger) screen would be so much better, for this purpose.
So I preordered a TouchDown straightaway and now wait when these become available.
What would be a great addition - are some physical buttons and a rotary encoder (for things like
volume, brightness, etc).
Even better if this could be also used to send MQTT commends. This way I could intergrate it into
smart home, and that would be really great.
Do you think any of these additions is possible? Without messing the code too much.
Many thanks!

Hi! 
love the project but i got a issue when im compiling the sketch i get an error saying
could any one point me to what is wrong? 

Arduino:1.8.13 (Windows Store 1.8.42.0) (Windows 10),
In file included from C:\Users\glenn\Documents\FreeTouchDeck\FreeTouchDeck.ino:301:0:
sketch\Touch.h: In function 'void touch_calibrate()':
Touch.h:39:9: error: 'class TFT_eSPI' has no member named 'setTouch'
tft.setTouch(calData);
^
Touch.h:61:9: error: 'class TFT_eSPI' has no member named 'calibrateTouch'
tft.calibrateTouch(calData, TFT_MAGENTA, TFT_BLACK, 15);
^
C:\Users\gleedv846\Documents\FreeTouchDeck\FreeTouchDeck.ino: In function 'void loop()':
FreeTouchDeck:676:19: error: 'class TFT_eSPI' has no member named 'getTouch'
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pressed = tft.getTouch(&t_x, &t_y);
^
FreeTouchDeck:714:19: error: 'class TFT_eSPI' has no member named 'getTouch'
pressed = tft.getTouch(&t_x, &t_y);
^
FreeTouchDeck:753:19: error: 'class TFT_eSPI' has no member named 'getTouch'
pressed = tft.getTouch(&t_x, &t_y);
^
FreeTouchDeck:831:19: error: 'class TFT_eSPI' has no member named 'getTouch'
pressed = tft.getTouch(&t_x, &t_y);
^
Multiple libraries were found for "WiFi.h"
Använd:
C:\Users\gleedv846\Documents\ArduinoData\packages\esp32\hardware\esp32\1.0.6\libraries\WiFi
Oanvänd: C:\Program
Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.42.0_x86__mdqgnx93n4wtt\libraries\WiFi
exit status 1
'class TFT_eSPI' has no member named 'setTouch'
This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Hi Glenn! That compile error shows up if in User_Setup.h, TOUCH_CS is not defined (probably
still commented out). Open the file:

/Arduino/libraries/TFT_eSPI/User_Setup.h

and make sure that it is the same as in the example (in the FreeTouchDeck repository) file.

Have fun!

:) some times you need to read the instructions more the one time! 
Thanks for your reply now it compiled just fine thanks for the help and what a great project!

Fantastic project, thanks for very clear instructions! Creating it went flawlessly. I created my own
casing in Blender. I use it mainly for Teams, Blender, OBS.
(https://www.thingiverse.com/thing:4836588/files)

Very nice project indeed! Especially with the WiFi setup page that allow easy configuration. I got
everything working, almost. Except that my Linux Mint computer does not recognize the
Bluetooth connection (my android phone does however). Which brought me to the following
thought: As I have to power the Esp32 with a USB adapter anyway, would it somehow be
possible to convert this from a 'Bluetooth' keyboard device into a native 'USB' keyboard device?

Hi Rudolf! The ESP32 BLE can have some trouble with certain Bluetooth connections. There are
however some good USB BT adapters that help with connection issues. Although I do not know

A Bluetooth ESP32 TFT + Touch Macro Keypad): Page 25

https://www.thingiverse.com/thing:4836588/files


about Linux Mint support....

The ESP32 doesn't have native USB support unfortunately. There is a possibility to use and
external IC that has USB HID support which then communicates over serial to the ESP32. I'm
looking in to that atm. So it is possible, but I do not have a clear answer right away....

Great job, thank you for sharing. I am using it on Ubuntu Linux and works perfectly. Using a 7''
screen and with more memory would be perfect.

Glad to hear @lunasf! I know, bigger would be better! :)

Hello Dustin,
we have build the device but after upload it says: Hard resetting via RTS pin...
then nothing screen is white i can connect via Bluetooth but the initail screen is not showing can
you give me a hint where to look or what to check 

Hi @erwinsanders! If the sketch is running (you can connect via BLE so I believe it is) I would
double check if the wires are correct. Also make sure that the User_Setup.h in the TFT_eSPI
library is the same as in the repository. You can also join me on Discord where we can debug
together (https://discord.gg/RE3XevS).

After uploading is always does a hard reset, so that is normal behavior. If you connect to it via the
Serial Monitor in Arduino, you should see some output. If it says "[WARNING]: SPIFFS
initialisation failed!" you can try uploading the config data to the ESP32 again, using the ESP32
Sketch Data Upload tool. If it boots normally, you should check the User_Setup.h and see if all
the pins that are used for the TFT are defined correctly. If you like to chat about it (maybe faster)
you can join my Discord: https://discord.gg/RE3XevS

Realy nice, well documented project and especialy useful with us all using Zoom and Teams all
day long. Used a modified case to house an on/off switch and a lipo with charger so the
touchdeck is wireless.
thanks al lot for this instructable

Wow! That look really great @pneuteboom! 

Do you have any idea whether an ILI9486 screen work instead of an ILI9488? Thanks!

Hi @huseyint15 ! Not out of the box. the ILI9486 uses a parallel interface and FreeTouchDeck is
written to use SPI screens. It might work with some modifications, but I can't say for sure.

Thanks Dustin.

You say don't use 5V to power it, use 3.3V. Does this mean you can't plug it into regular USB
since that's usually 5V+? How do you power this?

Hi @besxapacb You can't power the screen itself from 3.3V. The ESP32 has 3.3V available and
the IO's are also 3.3V. So you can use the USB on the ESP32, that's fine. Regular USB is fine. 
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This project is awesome. All steps are well explained. Thank you!

Thank you for building it!

Super well explained project and it works really well � Was able to use it as a starting point to
control Microsoft Teams �
How to build a Free Touch Deck to control Microsoft Teams

Very cool @joaoferreira1!

Hi Dustin. first i would like to thank you for documenting this. i think it is very cool to share such a
nice project for others to enjoy. i ordered a set of 10pcbs ( it says esp32 + tft combiner v1 ) . but
unfortunately my tft will not power up. is it a problem i soldered the SD0 MOSI pin ? or just some
mixup with drivers i compiled ?

also reordered 3 more tft's, (correct ones ili9488 ) , but the wrong Wroom-32u . i clicked the
wrong esp32 from the options on aliexpress. is there a way to make these work? 

I understand if it becomes to much timeconsuming, but if you can send me in the right direction
that would be awsome. 

Hi @rcampman! Sorry for the late reaction. I don't get notifications when someone post a
comment. There are a few things you can check. The MOSI pin should not be a problem. MOSI
is actually used, so you need that. MISO isn't used on the TFT but it is used for the SD Card
reader. 

What can be happening is (although I'm guessing) that the screen stays black because the
backlight is not on. In User_Setup.h you have to set the backlight pin and to be HIGH when on.
You can try and check that, and also the if the pin is actually high. (with a multimeter (should be
3V3) or with an led and a resistor to ground). 

I'd be happy to help you with some debugging, you can join my Discord,
https://discord.gg/RE3XevS where we can debug it when we are both online.

Hi,
Just built 1 out of 2 :) Nice little unit.

Wondering how do I execute a program via a button? Could not see a function in Configurator.

Hi, for now this is not possible without a piece of software on your PC. I'm currently developing
that software. If you like to be a beta-tester, you can join my Discord server!
https://discord.gg/RE3XevS

Hi Dustin,
Ok, I've joined your Discord :)
For the time being, I found by using shortcut keys, I can get programs started. However, of
course starting the exe directly is better.
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What a nifty little project! It took some fiddling to get it to work - read all the instructions very
carfully - the author was a tremendous help!

Cracking little toy! Works nicely with my MAC too. :-)
Thanks for this.. Next I'm looking to add this: https://www.hackster.io/alan707/zoom-button-a6cf6f
A stupid big button to exit zoom..

Still printing out the case on my CR-10. So far works great on the bench. I plan to order the PCB
also. Thanks for the effort on putting this together!! This will be a great learning tool for me,
spending time reviewing this as an intro to the esp32 and the TFT modules; both are new
components for me.

Dustin, you rock!
Thanks for spending your time on documenting this project. Excellent work, this looks/feels like
professional gear. Wish all my projects would reach this quality. This is definitely one of the best
contributions ever I have seen so far.
Hans

Thank you Hans for this amazing compliment! 

Got today my new Display WITH touch and tadaaa, all runs fine. 
Thank you all for your help. Still having issues, but not related to the freetouchdesk hard and
software.

Well! That is awesome! Maybe I can help with the unrelated stuff as well :)

Ordered parts from Amazon and did the PCB from pcbway. Need to find a power source for it yet
but probably have something around the house I could use. Any idea how long it will take for the
PCBs to arrive? China is always questionable on timing.

Hi nrd4lif! Any USB power source will be fine, it doesn't draw much current. PCB from PCBWay
usually arrive pretty quick, although it off course depends on the shipping method you have
chosen.
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